MacOS 10.12.3 上安装cocoapods遇到问题

在MacOS 10.12.3 上安装cocoapods遇到的问题,这里只说问题,其他的步骤正常走就行。
也可以参看这篇文章

1、问题一:

ERROR: While executing gem … (Gem::Exception) Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources

sudo gem update --system -n/usr/local/bin
sudo gem install -n /usr/local/bin cocoapods
pod setup

2、问题二:需要更新rvm(更新rvm是为升级Ruby)

Warning! PATH is not properly set up, ‘/Users/james/.rvm/gems/ruby-2.2.2/bin……
或是:
ERROR: Error installing cocoapods: activesupport requires Ruby version >= 2.2.2.
这就说明,你的ruby环境需要升级更新,可以查看一下你的ruby版本
$ ruby -v
1>. 安装rvm
RVM:Ruby Version Manager, Ruby版本管理器,包括Ruby的版本管理和Gem库管理(gemset)
$ curl -L get.rvm.io | bash -s stable
2>. 加载文件,测试是否安装正常(按照提示操作)
$ source ~/.bashrc
$ source ~/.bash_profile
$ source ~/.profile
$ rvm -v
3>. 查看当前ruby版本,获取rvm列表
$ ruby -v //查看当前ruby的版本
$ rvm list known //查看所有版本列表

4>. 安装ruby2.3
$ rvm install 2.3
安装过程中可能遇到如下错误:
Error running ‘requirements_osx_port_libs_install curl-ca-bundle automake libtool libyaml libffi libksba’,showing last 15 lines of /Users/acewill/.rvm/log/1468253599_ruby-2.3.0/package_install_curl-ca-bundle_automake_libtool_libyaml_libffi_libksba.log
原因是需要安装Homebrew, 参照stack overflow上的问题Installing RVM: “Requirements installation failed with status: 1.”
安装Homebrew, 通过以下命令:
$ ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”
5>.安装完Homebrew,重新安装ruby
$ rvm install 2.3
安装完ruby完后,查看一下是否更新成功
$ ruby -v

接下来就可以继续安装了。

3、问题三:参考问题二第四步

Error running ‘requirements_osx_port_libs_install curl-ca-bundle automake libtool libyaml libffi libksba’,showing last 15 lines of /Users/acewill/.rvm/log/1468253599_ruby-2.3.0/package_install_curl-ca-bundle_automake_libtool_libyaml_libffi_libksba.log
需要安装Homebrew

安装Homebrew, 通过以下命令:
$ ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”
安装完Homebrew,重新安装ruby
$ rvm install 2.3

4、问题四:

ERROR: While executing gem … (Errno::EPERM)
Operation not permitted – /usr/bin/pod
执行pod命令时,不管是否修改安装路径都出现下面错误。三个原因kennel造成这个问题。
1、gem版本太低,你需要更新gem
2、就是rvm版本太低,更新rvm后更新ruby。
3、安装路径有问题。参考一下问题一的安装

参考链接:
终端安装cocoaPods的方法
使用Cocoapods提示错误 Abort trap: 6 解决方法,RubyGems淘宝镜像管理失效解决方法

IT文库 » MacOS 10.12.3 上安装cocoapods遇到问题
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址