安装pg_rman是出现libpq.so.5()(64bit) is needed by …

[root@node2 tmp]#rpm -ivh pg_rman-1.3.3-1.pg96.rhel6.x86_64.rpm 
error: Failed dependencies:
	libpq.so.5()(64bit) is needed by pg_rman-1.3.3-1.pg96.rhel6.x86_64
	postgresql96-libs is needed by pg_rman-1.3.3-1.pg96.rhel6.x86_64
缺少libpq.so5()解决方法:
安装postgresql lib库
[root@node2 ~]# yum install postgresql-libs.x86_64  
在继续进行安装就可以了
[root@node2 tmp]# rpm -ivh postgresql96-libs-9.6.1-1PGDG.rhel6.x86_64.rpm 
warning: postgresql96-libs-9.6.1-1PGDG.rhel6.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 442df0f8: NOKEY
Preparing...                ########################################### [100%]
   1:postgresql96-libs      ########################################### [100%]
[root@node2 tmp]# rpm -ivh pg_rman-1.3.3-1.pg96.rhel6.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:pg_rman                ########################################### [100%]

IT文库 » 安装pg_rman是出现libpq.so.5()(64bit) is needed by …
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址